Negotiating SRTP and RTCP Feedback using the RTP/AVP Profile

Bernard Aboba, A. Hutton, Alan B. Johnston, Roland Jesske, Gonzalo Salgueiro · 2017

This document describes how the use of the Secure Real-time transport protocol (SRTP) [RFC3711]. can be negotiated using the AVP (Audio Video Profile) defined in [RFC3551]. Such a mechanism is used to provide a means for encrypted media to be used in environments where support for encryption is not known in advance, and not required. The same mechanism is also applied to negotiation of the Extended RTP Profile for Real-time Transport Control Protocol Based Feedback (RTP/ AVPF) [RFC4585].

Read the paper · More papers on PaperTik