Use of IP Router Alert Considered Dangerous

Reshad Rahman, David C. Ward · 2008

This document provides guidelines to address security concerns which arise with the use of IP Router Alert option [RFC2113] and [RFC2711]. RSVP,[RFC2205] and [RFC3209], and IGMP [RFC3376] are some of the protocols which make use of the IP Router Alert option. IP datagrams carrying the Router Alert option are usually examined in a router's slow path and an excess of such datagrams can cause performance degradation or packet drops in a router's slow path.

Read the paper · More papers on PaperTik