TCP Congestion Control Method Improvement Based On LwIP

Yan Li · Journal of Changchun Normal University · 2010

RFC2001 and RFC2081 documents give a description to TCP congestion control method,mainly including Slow Start,Congestion Avoidance,Fast Retransmit and Fast Recovery Algorithms;RFC2582 and RFC3782 documents take the detailed account of NewReno Modification to TCP's Fast Recovery.Combined with open source embedded TCP/IP Protocol Stack LwIP,this article gives a detailed description to the method of realizing Slow Start,Congestion Avoidance,Fast Retransmit and Fast Recovery Algorithms in LwIP.Moreover,improving suggestion to TCP congestion method is put forward according to the NewReno Modification to TCP's Fast Recovery.

Read the paper · More papers on PaperTik