High definition transport stream

Carlos Cabezas Martínez · 2007

El objetivo de este proyecto es estabilizar una plataforma capaz de proveer un entorno de videoconferencia de alta calidad sobre redes IP, usando el software de UltraGrid, el cual esta en estado de pruebas . En el proyecto se hace un estudio en profundidad de la transmision en tiempo real de video DV y sin compresion (CCIR-601), para ello se realiza un estudio de la red IP y sus protocolos de transporte UDP y TCP. A lo largo del proyecto se demuestra la necesidad de usar RTP (RFC 3550) trabajando sobre UDP para el correcto funcionamiento de la transmision en tiempo real. Se realiza un estudio del modo de encapsular el payload del RTP dependiendo del tipo de datos a transmitir. Se utiliza RFC 3189 para datos DV y RFC 4175 para la transmision de video sin comprimir . Dichas RFC’s se demuestran en un escenario LAN mediante el software UltraGrid con pruebas de transmision de DV a 30Mbps y video sin compresion, a 160Mbps(loopback), con su correcta reproduccion en el punto de origen en tiempo real del video transmitido a una alta calidad de imagen y un jiiter minimo. En las pruebas se realiza un estudio detallado del trafico demostrando el modo de transmision del RTP y consiguiendo senalar cada frame enviado y como consigue sincronizar emisor y el receptor y su reordenamiento de paquetes correspondiente. Durante el proyecto , Ultragrid estuvo bajo reformas y modificaciones para su correcta adaptacion en la plataforma Linux/GNU que fue instalado .Para ello fue necesario realizar un estudio sobre los sistemas Linux/GNU basados en Debian, y del lenguaje C. Todas las reformas son detalladas punto por punto en modo cronologico para que el lector comprenda el motivo de cada una de las decisiones tomadas. Como punto importante debo destacar que este trabajo me permitio estar en contacto con expertos mundiales de varios paises que estan a la vanguardia de la transmision de audio y video, destacando la participacion del Dr. Colins Perkins y Landan Gharai de la Universidad de Glasgow y de California respectivamente. Los cuales me han expresado sus diferentes puntos de vista en cuanto a la toma de decisiones a la hora de implementar sus sistemas. Este proyecto se enmarca dentro de un proyecto de investigacion de la Fundacio i2cat, llamado V3 (Video, Videoconference and Visualization). Su objetivo principal es la creacion de un sistema de videoconferencia en tiempo real en alta definicion. El proyecto se encuentra en su fase inicial, habiendo trabajado en entornos parecidos en otros proyectos anteriores, donde el knowhow referente a la transmision en tiempo real de flujos de alta definicion ha llevado al grupo de trabajo del proyecto a decantarse por UltraGrid como software base de investigacion para este entorno.

Read the paper · More papers on PaperTik