Recent Changes to Privacy Enhanced Electronic Mail

Matt Bishop · 1993

Privacy enhanced electronic mail is a set of protocols which provide confidentiality, authenticity, and integrity for electronic mail. A version of these protocols was released in August 1989, and revised two years later. Since then, several other changes were made to the protocols, many of them minor, but some major. This note describes these changes. 1. IntroductionPG A previous paper [1] described the privacy enhanced electronic mail protocols proposed in RFC 1113, RFC 1114, and RFC 1115 [2][3][4], along with changes made through June 1991. These protocols provide sender authenticity, message integrity and confidentiality, and under certain circumstances non-repudiation. A key tool for these protocols is cryptography; first, the message is encrypted using one cryptosystem and key (the session key), and then that key and algorithm identifier are themselves encrypted by a second cryptosystem and key (the interchange key). Support for both symmetric and asymmetric session and interch...

Read the paper · More papers on PaperTik