Performance and comparative analysis of energy consumption for mobile ad hoc routing protocols

Kunagorn Kunavut · 2014

Mobile ad hoc networks are energy-constrained networks, nodes in these networks are usually mobile and they are typically implemented in the specific areas where electrical power source is not available. Thus, the operations of these nodes must only rely on battery power or other exhaustible sources of energy. In addition, most of power in each node is required for communication with other nodes or gateway connected to the wired networks, this usually includes transmission of data and control overhead generated by ad hoc routing protocols to obtain the best paths to destination nodes/devices. Thus, to study the energy consumption of each routing protocol is one of the major concerns. In this work, number of simulation scenarios are constructed to study the energy consumption in each node using various routing protocols standardized by the Internet Engineering Task Force (IETF) MANET working Group which are OLSR (RFC 3626), DSR (RFC 4728) and AODV (RFC 3561).

Read the paper · More papers on PaperTik